1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

UOSteam Intel ICD OpenGL Driver Error

Discussion in 'Guides' started by parsnip, May 21, 2017.

  1. parsnip

    parsnip Moderator Staff Member

    1,450
    1,697
    113
    Jul 11, 2013
    This is a little guide for things to try if you get the dreaded "cannot find the name of Intel ICD OpenGL driver" error when loading UOSteam.

    A simple solution that works for many is to roll back your graphics driver but this isn't a very sustainable solution in the long run.

    A slightly more complex solution is to move driver files and tweak some registry settings. The following steps worked for me and one other person so far - Hopefully it proves useful for others!

    Update: @Fuschino created a great video running through this guide. Check it out if you are at all unsure about the steps.

    Video Guide by Fuschino:



    Original Guide:

    Get your graphics card GUID
    1. Open Device Manager from Control Panel (or devmgmt.msc from command prompt)
    2. Navigate down to your graphics card under Display Adapters
    3. Double-click on the graphics card entry to load its Properties
    4. Click on the Details tab
    5. Click the Property drop down and select Class GUID
    6. Take note of this value (Mine was {4d36e968-e325-11ce-bfc1-08002be10318})
    [​IMG]

    Find the registry entry for OpenGL
    1. Open your registry (Type regedit in your command prompt or press WindowsKey-R to open the Run prompt and type regedit.exe in there)
    2. Navigate to the following entry: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{YOURGUIDHERE}\0000
    3. Scroll down to OpenGLDriverName and OpenGLDriverNameWoW
    4. Take note of the path of the .dll files in those two registry entries For example, my paths were: C:\Windows\System32\DriverStore\FileRepository\igdlh64.inf_amd64_4ac0038ddc82c1c6\ig9icd64.dll and C:\Windows\System32\DriverStore\FileRepository\igdlh64.inf_amd64_4ac0038ddc82c1c6\ig9icd32.dll
    5. Leave the regedit open, we'll come back to that in a moment but first ....
    Go to the Driver folder
    1. Open Windows Explorer and navigate to the location of those files we found in the registry. For example, in my case, this was C:\Windows\System32\DriverStore\FileRepository\igdlh64.inf_amd64_4ac0038ddc82c1c6\
    2. Copy the two files (ig9icd64.dll and ig9icd32.dll), navigate to C:\Windows\ and paste a copy of the files there (Ctrl-V)
    3. You should now have a copy of the files under the original location and under C:\Windows\
    [​IMG]

    Edit the registry
    1. Open regedit again and double click on OpenGLDriverName
    2. Change the entry to remove the path, leaving just the file name. For example, C:\Windows\System32\DriverStore\FileRepository\igdlh64.inf_amd64_4ac0038ddc82c1c6\ig9icd64.dll becomes ig9icd64.dll
    3. Repeat the process for OpenGLDriverNameWoW (It should look something like the image below)
    4. Close the registry editor
    5. Restart your computer
    [​IMG]

    Now try loading UOSteam - You should now be free of errors!
     
    Last edited: Jun 8, 2017
    MrParker, Chediak, Firecrest and 7 others like this.
  2. Grish'nak

    Grish'nak Well-Known Member

    219
    182
    43
    Mar 10, 2016
    Grish'nak
    @parsnip guided me through this process very helpfully this morning. It worked following a computer restart.

    Thanks for your patience with me - top vegetable!
     
  3. Alucard

    Alucard Well-Known Member

    1,023
    962
    113
    Dec 29, 2013
    Mega respect for this Guide !!!
    I somehow solved the problem differently, but I had to spend a lot of time, for the future now we have a solution
    Thx !
     
  4. Young Star

    Young Star Well-Known Member

    2,337
    1,912
    113
    Jul 6, 2015
    Bryden Rivers, YoungStar, Young Star, Tom Sevenstreams
    Thanks for posting a possible solution. I know a few people that have hit this problem when getting a newer computer.
     
  5. Eternal Dragon

    Eternal Dragon Well-Known Member

    307
    90
    28
    Oct 7, 2015
    Eternal Dragon, Eternal Shield, Eternal Dancer, GoreTex
    how did you resolve it? unfortunately this didnt work for me...
     
  6. parsnip

    parsnip Moderator Staff Member

    1,450
    1,697
    113
    Jul 11, 2013
    Happy to try and walk you through the steps on uoforever if my instructions here weren't clear enough.
     
  7. Alucard

    Alucard Well-Known Member

    1,023
    962
    113
    Dec 29, 2013
    1) this problem on mine Chinese mini PC solved with uninstall Microsoft drivers and install manufacturer drivers on Intel HD videocard
    fkn microsoft reupdate drivers, But I pointed out to use the other default drivers


    2) Also this problem was on mine new Laptop Dell 6567 = i have integrated video ~ Intel HD 620 + Nvidia 1050 4GB
    i tryed many different drivers - original Intel, manufacturer Dell...
    and i don't understand what helped rollback\install\reinstall drivers
    or after all - deleting Game from default folder and copy Game folder from mine PC to Notebook and start UoSteam Game from D:\ ... directory
     
  8. parsnip

    parsnip Moderator Staff Member

    1,450
    1,697
    113
    Jul 11, 2013
    Success for 3 people so far (including myself). Unfortunately it didn't work for Eternal Dragon. We managed to get a different error message but no progress beyond that. The instructions may not work for people with 2 graphics cards (e.g. Intel and NVidia). If I think of any other tricks, I'll update the original post.
     
  9. Eternal Dragon

    Eternal Dragon Well-Known Member

    307
    90
    28
    Oct 7, 2015
    Eternal Dragon, Eternal Shield, Eternal Dancer, GoreTex
    I wonder if I just have my nvidia card disabled while I play uo
     
  10. Naww

    Naww Active Member

    30
    28
    18
    Aug 22, 2014
    man, you literally saved my life, thank you so much, had this issue and couldn't play using steam.
    But i got another question. I have 2 videocards, and my built-in videocard ( lol, same as yours, intel 620 hd) is somewhat crappy and i would like to use my nvidia one. Forcing it through adding UOsteam or client.exe in nvidia panel doesn't seem to do anything.
     
    Alucard and parsnip like this.
  11. Fuschino

    Fuschino Well-Known Member

    114
    74
    28
    Dec 11, 2012
    This solved the problem for me! Thanks to Parsnip for helping me in uoforever with it also!
     
    parsnip likes this.
  12. parsnip

    parsnip Moderator Staff Member

    1,450
    1,697
    113
    Jul 11, 2013
    Updated original post with a link to an excellent video guide created by @Fuschino.
     
    Fuschino likes this.
  13. Bring tax

    Bring tax Well-Known Member

    58
    26
    18
    Sep 27, 2015
    think i had this problem once before, i just changed program to run off motherboard graphics instead of G-card
     
  14. HibbiGibbi

    HibbiGibbi New Member

    3
    4
    3
    Jul 23, 2017
    I started experiencing this problem in November of 2016. This solution worked for me, but I had to do a small tweak......

    First- I watched the video and followed the guide provided here.

    Now, I'm not the most "computer literate" guy, but I managed to follow the directions and changed my registry as instructed. However it still did not fix the issue.

    So- on a whim- what I did was go to my device manager/display adapters/ and uninstall the INTEL Integrated 530. This left only my NVIDIA 1060 showing up as a display adapter.

    Then I went back in and edited my registry.....but this time in the "0001" folder, not the "0000" folder as shown in the video. See picture below. Changing the OpenGLDriverName and the OpenGLDriverNameWoW to the values shown and then restarting the computer fixed the issue!

    Watch the video and give it a try first. IF that doesnt work, try changing the value in your "0001" folder.

    The last thing I'll say as a disclaimer... I AM NOT A COMPUTER KNOWLEDGEABLE PERSON! IF YOU DO ANYTHING FOLLOWING THIS AND MESS UP YOUR COMPUTER I AM NOT RESPONSIBLE!

    Dont know if that's necessary.....but as a FYI I made a system restore point before I went fooling around in my registry.....

    I dont know *why* doing it this way worked...but it did. Hope it serves others as well.

    OpenGL.JPG
     
    parsnip likes this.
  15. Chediak

    Chediak Well-Known Member

    114
    50
    28
    Oct 31, 2013
    Factavi
    After a windows update, I encountered this problem again, and this solution took care of it quite nicely! Thank you
     
    parsnip likes this.
  16. Chediak

    Chediak Well-Known Member

    114
    50
    28
    Oct 31, 2013
    Factavi
    It turned out that following this method made my computer incompatible with Orion client. An alternative fix -- and what worked for me to resolve both issues, was to find the most recent Intel Graphics Driver. My laptop would not allow me to install it initially (a validation error), which I circumvented by following these steps. Now laptop has the most up to date graphics driver from intel, and runs both UOSteam and Orion client without error.
     
  17. jorge

    jorge Active Member

    41
    36
    18
    Dec 3, 2013
    Thanks for the input everyone. The original steps from @parsnip did not work for me but I found that updating to the latest drivers for my Intel 630 Graphics (via Device Manager) solved the issue for me.
     
  18. Young Star

    Young Star Well-Known Member

    2,337
    1,912
    113
    Jul 6, 2015
    Bryden Rivers, YoungStar, Young Star, Tom Sevenstreams
    I was able to get steam to work for me by rolling back the drivers but then I had another windows update and it stopped again. I thought I would try this work around instead but when I went through the steps my registry already had the full path removed like what is instructed to do. All that is listed for the:
    Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000
    OpenGLDriverName = ig9icd64.dll
    OpenGLDriverNameWow = ig9icd32.dll

    I tried to go to the path where the guide said they were located and found the files there and copied them up to the C:\Windows directory but it didn't have any effect when I restarted my computer. :(

    I was just on this morning too and saw that there were some updates that wanted to install when i restarted. I had to restart for a different reason and it auto-updated on me. Grr. Now even rolling back the drivers doesn't fix it.

    **UPDATE**
    Tried to see if I could get that latest driver that was linked above but got the validation error too. Followed the next link about circumventing that and it worked. When I looked at the date of the driver that the default update driver installed it was dated back in 2016 some time. This latest one that I got from the link is dated for August 2017.
     
    Last edited: Sep 18, 2017
  19. MrParker

    MrParker Active Member

    38
    5
    8
    Jan 20, 2014
    This worked! Thank you so much guys!!!!!!!!!!!!!!!!
     
    parsnip likes this.
  20. Cheesestick

    Cheesestick Well-Known Member

    179
    30
    28
    Nov 7, 2013
    If you open the settings folder under 000x folders you can see what video card the settings are applying to. I had previous GPUs on this machine and i have quite a few. Here is how I found my current GTX1080's registry keys for this fix. Seeing this I knew I had to make the changes on 0003.

    upload_2017-9-27_19-43-15.png
     
    parsnip likes this.

Share This Page